Exalate isn't Loading After an Update

    This article applies to Exalate Classic only. If you're using the New Exalate experience, please refer to the New Exalate documentation.

    Problem

    In some cases, Exalate won't load when updated to a newer version.

    Cause

    One of the reasons for this problem is the lack of tablespace in the database. If the net.java.ao package is in DEBUG level, after re-enabling Exalate, you will see the following message in the logs:

    ORA-01658: unable to create INITIAL extent for segment in tablespace JIRA_DATA

    To identify this problem:

    1. Navigate to Administration > System > Logging and profiling.

    2. Enable the DEBUG level for net.java.aopackage.

    3. Navigate to Administration -> Add-ons -> Manage apps.

    4. Click Exalate.
    5. Click Disable.

    6. Click Enable.

    Solution

    You can resolve the issue by extending tablespace in the database with one of these queries:

    • Enlarge one of the existing data files:

      ALTER DATABASE 
      DATAFILE 'C:\ORACLEXE\APP\ORACLE\ORADATA\XE\JIRA_DATA.DBF' 
      RESIZE 3000M;
    • Add a second data file to the tablespace:

      ALTER TABLESPACE ts_data 
      ADD DATAFILE 'C:\ORACLEXE\APP\ORACLE\ORADATA\XE\JIRA_DATA2.DBF' 
      SIZE 1000M;
    • Allow the datafile to auto-extend:

      ALTER DATABASE 
      DATAFILE 'C:\ORACLEXE\APP\ORACLE\ORADATA\XE\JIRA_DATA2.DBF'
      AUTOEXTEND ON
      MAXSIZE UNLIMITED; -- Or some reasonable cap